Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Next »

SiteMesh is a Servlet Filter and therefore requires a container that conforms to the Servlet 2.3 specification.

As SiteMesh is written in pure Java, it is platform independent.

SiteMesh is tested and works on the following Servlet containers:

The only other requirement of SiteMesh is JAXP (with a parser implementation). This should be supplied by your servlet container.

SiteMesh is compatible with JRE 1.3 and higher. For best performance, JRE 1.4.x or higher should be used.

To build SiteMesh from the sources, you must have the Java SDK version 1.4 or above, and Jakarta Ant version 1.5 or above.

Service Packs and Patches

SiteMesh currently does not work flawlessly on Weblogic 6.1, 7.0 and 7.0 SP1. For more information, visit http://jira.opensymphony.com/secure/ViewIssue.jspa?id=10045. However, SiteMesh does work correctly on WebLogic 7.0 SP2, 8.1 and 8.1 SP2.

SiteMesh does not work on Weblogic 8.1 SP1 because of various bugs in the JSP compilation engine. Apply patch CR112789_81sp1 to your Weblogic installation.

SiteMesh does not work on WebSphere 5.0.1 and 5.0.2. Apply patch IBM iFix PQ80592 to your WebSphere installation.

  • No labels