Skip to end of metadata
Go to start of metadata

SiteMesh is a Java Servlet Filter and requires a container that,

  • Conforms to Servlet 2.3 or higher specifications
  • JAXP with a parser implementation (this is usually supplied by your Servlet container)
  • JRE 1.3.x and JRE 1.4.x or higher for optimal performance

SiteMesh may also be built from source, with Java SDK version 1.4 or above, and Jakarta Ant 1.5 or above.

SiteMesh will generally work with most modern Servlet containers. Some of the containers tested and submitted to us out in the field are listed below,

Icon

If you know of other application servers please let us know.

Compatibility Issues

In rare cases specific products do not work with SiteMesh,

Container

Issue

Fix if Available

Further Details

SiteMesh Version

WebLogic 6.1, 7.0 and 7.0 SP1

WebLogic bug results in requestDispatcher.forward() or requestDispatcher.include() failure.

WebLogic patch

Jira Ticket 10045

 

WebLogic 8.1 SP1

SiteMesh does not work due to various bugs in the JSP compilation engine.

Apply patch CR112789_81sp1 to your Weblogic

 

 

WebSphere 5.0.1 and 5.0.2

 

Apply patch IBM iFix PQ80592

 

 

Community Submitted Testing

SiteMesh has been tested on a number of containers. If you are using SiteMesh please share your results with us,

Container

Versions Tested

SiteMesh Version

Tomcat

6.0.18, 6.0.20, 6.0.26

2.3.1

WebSphere

 

 

 

 

 

  • No labels